Natively

Provider issues
Resolved·Partial outage

AWS have announced no more issues

Tue, Oct 21, 2025, 03:40 AM
(1 month ago)
·
Affected components
Website
Updates

Resolved

AWS have announced no more issues

Tue, Oct 21, 2025, 03:40 AM

Investigating

Improved situation, you may still experience issues

Mon, Oct 20, 2025, 07:26 PM(8 hours earlier)

Investigating

Difficulty accessing projects and prompting

Mon, Oct 20, 2025, 03:52 PM(3 hours earlier)
Powered by